Bluehost Server Down - Affecting Most Services
Incident Report for Team 1225, The Gorillas
Resolved
This incident has been resolved.
Posted Sep 25, 2021 - 08:30 EDT
Identified
Our hosting service, BlueHost is having server problems at the moment.
This issue may affect Team 1225 website and Link redirection services.

The Bluehost team is working hard to resolve this issue as fast as possible.

Check our status page for all the latest updates.
Posted Sep 24, 2021 - 20:40 EDT
This incident affected: Main Website, Bluehost Server Status, and Team 1225 Link Redirecting Service.