Web Sserver Down
Incident Report for Team 1225, The Gorillas
Resolved
Due to a hosting error, our web server was down momentarily.
Posted Sep 14, 2020 - 08:07 EDT
Investigating
We are currently investigating this issue.
Posted Sep 14, 2020 - 08:02 EDT
This incident affected: Main Website.