Contact page unavailable.
Incident Report for Team 1225, The Gorillas
Resolved
This incident has been resolved.
Posted Feb 24, 2021 - 17:07 EST
Monitoring
We have fixed the Contact Us page and are running tests on it.
Posted Feb 24, 2021 - 16:54 EST
Investigating
The contact-us page of our website is currently down for emergency repairs. The rest of our site remains unaffected.
Please check back for updates.
Posted Feb 23, 2021 - 23:57 EST
This incident affected: Main Website.